Hamachi:Synchronize ACT! 2005

From LogMeInWiki

Jump to: navigation, search

Contents

Overview

You would like to synchronize your ACT! 2005 database with other ACT! users over a Local Area Network (LAN), Wide Area Network (WAN), or Virtual Private Network (VPN). Application Synchronization is designed to update your Subscriber (or Remote) copy of the database with the latest changes made by other users as well as send your changes to the Publishing (or Parent) database so that other remote users can receive them.

Detail

Important Note: If you are synchronizing a database, ensure that you and your sync partners are using the same version of ACT! 2005. You can verify your installed version number by clicking About ACT! from the Help menu. The version number is displayed as Version 7.0.x in the upper-right corner.

This document will provide you with the steps needed to perform Application Synchronization. Detailed information on enabling synchronization, creating a Sync Set, and creating a Remote database is included. For Application Synchronization to work, you will need to ensure that the Publishing database is open and has Accept Incoming Syncs enabled. Please refer to the appropriate section below:

If you are using the Windows XP operating system, you must disable the XP firewall before attempting Application synchronization. (per ACT! KB, not confirmed)

Note: The Publishing (or Parent) database refers to what has been known as a Master database in previous versions of ACT!. ACT! 2005 uses a Publisher - Subscriber relationship. The Subscriber (or Remote) database will initiate all synchronization. Remote databases can only be created from the Parent database and then must be moved to the remote computer. A Remote database can only synchronize with their Parent database.

You can determine whether you are in a Publisher (Parent) or a Subscriber (Remote) database by following the steps below:

1. Click the Help menu, and then click About ACT! The About ACT! dialog box appears.
2. Click the Database Info button, the Database Information dialog box appears.
3. image:act_1.gif
4. Scroll to the bottom of the Database Settings Information window (as Illustrated above). If the Sync Enabled value is True, Sync Role will display either Publisher or Subscriber.

Note: Sync Role will not display as Publisher until a remote database has been successfully created from the Parent (Publisher) database.

Setup Hamachi

At this point, you'll set up Hamachi on both machines, sync publisher, and subscriber, and confirm connectivity (ping). See Getting Started Guide for help setting up.

All connectivity would then be achieve via Hamachi IP addresses.


Enable Synchronization

In order to perform any type of synchronization in ACT! 2005 the Publishing (or Parent) database will need to have synchronization enabled. Use the following steps to enable synchronization:

1. Launch ACT!
2. Open the Publishing database.
3. Click Synchronization Panel from the Tools menu. The Synchronization - Select a Synchronization Task dialog box appears.
image:act_2.gif
4. Click Enable Synchronization. The following ACT! dialog box appears.
image:act_3.gif
5. Click Yes to enable synchronization.

The Accept Incoming Syncs option must be enabled in the Publishing (Parent) database. Follow these steps:
1. From the Publishing database; click the Tools menu, point to Synchronize, and then (if it is NOT enabled) click Accept Incoming Syncs. The following ACT! dialog box appears.
image:act_4.gif
2. Ensure that the Port number is correct, and then click OK. The following ACT! dialog box appears.
image:act_5.gif
3. Click OK to complete the process.

Synchronization is now enabled for the Publishing database.


Create a Sync Set

An important part of preparing for synchronization is to create a Sync Set. A Sync Set defines the ACT! 2005 synchronization Users and the list of contact records that you wish to include in the synchronization. The Sync Set can be limited to one remote user and one contact or can include all users and all contact records in your ACT! 2005 database. The contact records included in the Sync Set are identified through an advanced query that defines the Sync Set Criteria. Follow the steps below:

1. Launch ACT!
2. Open the Publishing database.
3. Click Synchronization Panel from the Tools menu. The Synchronization - Select a Synchronization Task dialog box appears.
image:act_6.gif

4. Click Manage Sync Set. The Synchronization - Create, Copy, Edit, or Delete Sync Sets dialog box appears.
image:act_7.gif

5. Click Create New Sync Set from the Sync Set Task box. The Synchronization - Enter Sync Set Name and Description dialog box appears.
image:act_8.gif

6. Sync Set name: Type in a unique name for your Sync Set. In this example we will be using "Oregon and California".
7. Description (Optional): This optional field allows you to provide more detailed information on your Sync Set.
8. Click Next. The Synchronization - Select Users dialog box appears.
image:act_9.gif
9. In the Synchronization - Select Users dialog you will identify the users you would like to synchronize this Sync Set with.

  • Enabling the All current and future users of this database will allow you to sync with all the users of this database.
  • Enabling the Selected users option will allow you to select specific users of this database you would like to synchronize with. To select a user click on the user's name in the left pane, and then click the single arrow to the right . Continue this until all the users you wish to synchronize with appear in the right pane. When you have finished making your selections. Click Next. The Select Contacts dialog box appears.

image:act_10.gif

10. In this dialog box, you identify the contact records that will be synchronized with this Sync Set:

  • Enabling the Synchronize all available contacts will allow you to synchronize all of your contacts with all the users of this Sync Set.
  • Enabling the Define Sync Set criteria will allow you to create an Advance Query to define your criteria. This is how the Publishing database will determine which Contacts to synchronize with the remote users.
  • Total number of available contacts: displays the number of contact records that are available be synchronized from this database.

If you enable the Synchronize all available contacts option, and then click Next. The Sync Set Confirmation dialog box appears.
image:act_11.gif

You may click Back to edit your Sync Set or Finish to complete it. The Synchronization - Create, Copy, Edit, or Delete Sync Sets dialog box reappears with your Sync Set displayed.
image:act_12.gif

At this point you have the options to Create, Edit, Delete, or Copy your Sync Sets.

A Remote database will need to be created for each remote user you are synchronizing with. This database file will contain all the Contacts, Notes, Histories, Activities, and Opportunities included in the Sync Set. It can also contain supplemental files and attachments. A Remote database has a file extension of .RDB and is generally very large. You can create this .RDB file on your computer or (through a Local Area Network) the remote computer that it will be used on. You will not, in most cases, be able to e-mail this .RDB file as an attachment. For example; a Remote database created for the ACT7Demo will produce a file that is over 7MB (megabytes) in size. Other methods of delivering the .RDB file can be to burn it to a CD that the remote user can then restore on their computer, or use an FTP (File Transfer Protocol) Site. Use the following steps to create a Remote database:

1. Launch ACT!
2. Open the Publishing database.
3. Click Synchronization Panel from the Tools menu. The Synchronization - Select a Synchronization Task dialog box appears.
image:act_13.gif

4. Click Create Remote Database. The Synchronization - Enter Remote Database Name and Location dialog box appears.
image:act_14.gif

5. Identify the name and location of the Remote database in this dialog box.

  • Remote Database Name: Type in the name for the Remote database. Must begin with a letter, contain only letters, numbers, and underscore characters. Must be less than 32 characters long.
  • Location: Indicates where the Remote database file (.RDB) will be located. To select a different location; click the Browse button, and then navigate to and click the folder where you would like to save the new Remote database.

6. Click Next. The Synchronization - Select a Sync Set dialog box appears.
image:act_15.gif

7. You must select a Sync Set for the Remote database to synchronize with. If you have not yet created a Sync Set, you will need to Cancel this process. For more information on creating a Sync Set, please see the section labeled Creating a Sync Set above. After you have selected the Sync Set, click Next. The Synchronization - Database Synchronization Options dialog box appears.
image:act_16.gif

8. You may enable the synchronization of supplemental files and/or attachments in this dialog box.

  • Enabling the Allow database supplemental files to synchronize will include default and customized Layouts, Reports, Document Templates, and Queries.
  • Enabling the Allow attachments to synchronize option will include Documents and E-mails that are attached to Contacts in the Sync Set.
  • Set the number of days that synchronize expires: This setting will stop synchronization with this Remote database if there is no sync performed in the time specified. The default is 30 days.

9. Click Next. The Synchronization - Sync Server Connection dialog box appears. You have two options at this point in the wizard for Connection Type: Network (inside a firewall) is used for Application Synchronization. Do Not select Internet (outside a firewall). This option is only available in ACT! 2005 Premium for Workgroups.
image:act_17.gif

10. The Synchronization - Sync Server Connection dialog box includes the following three items:

  • Connection Type: Use the drop- down and click Network (inside a firewall)
  • Enter the Machine Name of the computer hosting the Main database: This will be populated automatically and may be changed. However, changing the Machine Name is not recommended.
  • Enter the Port number being monitored by the sync server: This will be populated automatically and may be changed. However, changing the Port Number is not recommended.

11. Click Next. The Synchronization - Building the Remote Database dialog box appears.
image:act_18.gif

12. You can set a password to protect the Remote database from being restored by unauthorized users. This is helpful if you place a Remote database on a website or FTP (File Transfer Protocol) site for remote users to download.
13. Enable the File is password protected, type the Password and then enter the same password into the Confirm Password field.
14. Click Back to make any changes that you would like or Finish to create the Remote database (.RDB) file. A Progress indicator appears as the Remote database is created.
image:act_19.gif

15. When the Remote database has been created, the following ACT! dialog box appears.
image:act_20.gif

16. This message displays the name and location of the Remote database.

  • Click Yes to create another Remote database. The Synchronization - Enter Remote Database Name and Location dialog box reappears.
  • Click No. The Synchronization -Select a Synchronization Task dialog box reappears. Click Close to return to ACT!.

Important Note: The Accept Incoming Syncs option must be enabled in the Publishing (Parent) database. Please refer to the Enabling Synchronization for the Publishing Database: section above.

Restore Database

The remote users will need to Unpack and Restore their Remote database before they will be able to synchronize. Use the following steps to Unpack and Restore Remote Database:

1. Click the File menu, point to Restore, and then click Database. The current database closes as the Restore Database dialog box appears.
image:act_21.gif

2. In the Select type section, enable the Unpack and Restore remote Database option, and then click OK. The Restore an ACT! remote Database dialog box appears.
image:act_22.gif

3. From the Select the remote database file to restore field, click the Browse button to locate and open the Remote database (.rdb) file, and then (if necessary) from the Database Location field, Browse to the directory where you wish to restore the database. You may enable the Share this database with other users option here, if desired.
4. Click OK. A Restore Database progress indicator appears as your Remote database is unpacked and restored.
image:act_23.gif

5. The following ACT! dialog box will appear once the restoration has successfully completed. image:act_24.gif

6. Click OK.
7. To open this database, click the File menu, and then click Open Database, or click the Open Database button. An Open dialog box appears.
8. Navigate to (if necessary) and Open the database (.PAD) file.

Note: Unpacking and Restoring the .RDB file will create the .PAD, .ALF and .ADF files as well as the database files folders that make up an ACT! 2005 database.

You will also need to ensure that the Accept Incoming Syncs option is enabled for the Publishing database. Once all of these tasks have been completed, you are ready for your remote users to synchronize.


Synchronizing

Remote users must initiate all synchronization. Follow the steps below to initiate synchronization from a Remote database:

1. Launch ACT!.
2. Open the database you would like to synchronize.
3. Click the Tools menu, point to Synchronize, and then click Synchronize Now. The Sync in Progress indicator appears.
image:act_25.gif

4. You may enable the Auto minimize in task bar option to hide this window. ACT! 2005 Synchronize is designed to run in the background. You will receive a message when the Synchronization is complete. For information on your synchronization, refer to View Sync Log option in the Synchronization Panel.


Was this article helpful?
Add to: del.icio.us | Digg | Slashdot

Personal tools